DigitalChalk requires the Flash plugin version 9 or higher to be installed on the users computer for proper Chalkboard functionality. If you would like to download the latest version of the Flash plugin please visit http://www.adobe.com and download the appropriate flash player for your computer.


Click Here to have Adobe automatically check and display your Flash player version


If after checking your Flash version you find that you are using version 9 or higher, please report your version and browser information along with a detailed problem description to support@digitalchalk.com, we will look into the issue immediately.